MS Exchange | Contacts are not being listed in the "Book Address"

Incident Report for Followup CRM

Update

We are continuing to investigate this issue.
Posted Apr 07, 2021 - 00:06 UTC

Investigating

We are currently investigating this issue.
Posted Mar 29, 2021 - 19:46 UTC