Sales Leader: filter by contract type
Incident Report for Followup CRM
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2022 - 18:46 UTC
Investigating
We are currently investigating this issue.
Posted Apr 01, 2022 - 17:00 UTC
This incident affects: CRM.