Monthly Captured Contracts Issue

Incident Report for Followup CRM

Update

We are continuing to investigate this issue.
Posted Jun 04, 2021 - 19:21 UTC

Investigating

We are currently investigating this issue.
Posted Jun 04, 2021 - 19:20 UTC
This incident affects: CRM.