Lost bids Closing Ratio Chart Date Issue (Bid Date not within range)
Incident Report for Followup CRM
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2021 - 14:14 UTC
Investigating
We are currently investigating this issue.
Posted Aug 25, 2021 - 14:52 UTC
This incident affects: CRM.