Dataforma Issue: Wrong State
Incident Report for Followup CRM
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2022 - 14:05 UTC
Investigating
We are currently investigating this issue.
Posted Feb 10, 2022 - 15:26 UTC
This incident affects: CRM.