Dashboard bug
Incident Report for Followup CRM
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2021 - 19:20 UTC
Investigating
We are currently investigating this issue.
Posted Jun 01, 2021 - 16:13 UTC
This incident affects: CRM.