Error message when connecting to google
Incident Report for Followup CRM
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2021 - 20:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 02, 2021 - 19:19 UTC
This incident affects: CRM.